Home About Rice Downloads Documents Others Cooker CookerGX
Documents  >  Tutorial  >  environment
Necessary environment.

The .Net Framework

The Rice language is provided as a library for the .Net Framework on Windows.

The Rice language has been implemented for the .Net Framework version 4.0 in C#, however, a target of the Cooker (Rice execution environment for the tutorial) is a version 4.6.

Therefore, you will need the .Net Framework version 4.6 or later in order to proceed with the tutorial.

Text Editor

Rice source file need be the UTF-8 encoded text files.

Therefore, you will need a text editor that can handle the UTF-8 encode in order to proceed with the tutorial.

Cooker

Cooker is an application for Rice language evaluation. It will work with .Net Framework versions 4.6 or later.

Rice code in this tutorial is a sample code to execute on the Cooker.

Next
Previous
Copyright © Rice All rights reserved.